Add iOS 9.3.* support to Xcode 7.2.1

Apple does not support Xcode 7.3 and iOS 9.3.1 on Yosemite 10.10.5, so you can only use Xcode 7.2.1 and iOS 9.2.

If your device version is higher than iOS 9.2, for example iOS 9.3.1. you will get this error when try to run or debug on your device!

Error

Error:

And here is how to fix this problem without need to install OS X El Capitan 10.11.*


1. Download Xcode 7.3.1 from Apple site (requires to be logged).

Download Xcode 7.3.1

2. Open Xcode_7.3.1.dmg and click show package content.

Show package content

 

3. Close Xcode 7.2.1.
4. Copy version.plist from Xcode 7.3.1 (dowloaded one) folder

From:

and paste/replace to Xcode 7.2.1 (installed one)

5. Copy SDKs

From

to

6. Finally DeviceSupport/9.3 (13E230)

Copy the version folder “9.3 (13E230)

to

 

Now you should have iOS 9.3 in target list

iOS 9.3 in the list

beBoss

Живота е като терена или ставаш силен, блокираш, сваляш и оцеляваш или се отказваш, падаш и си заминаваш ! beBoss™